Sonny Kristoffer Lachica's Website

This website is under construction
Please visit my other website:
http://sonnylachica.webnode.com

This Page is for...

- General Hardware Info

- Nexus (NX-OS)

- CRS and ASR (IOS XR) 

- Exams and Certification Info 

- R&S Experiences

How to Read Effectively

I was surprised by how much I enhanced my reading skills. If you are reading a Technical book, chances are you'll fall asleep before even finishing a page. As I read tons of books, I learned that there is a system in reading a book.

This is how you efficiently and successfully read a book:

 1. Read the Title Page

 2. Know the Author(s)

 3. Know the year the book was published. 

 4. Read the Introduction/Preface 

 5. Read the Table of contents, this is very important.

 - The table of contents will give you an overview of what you need to study. It is like familiarizing yourself to everything, without knowing the details yet.

 6. Read per chapter, but at your first time of reading this book, DO NOT READ EVERYTHING.

 - No one can go head-on and read a book and understand everything in there. If you can do that, congratulations, but for humans, most of us can barely survive 10 pages. So better be more efficient. Read only the important details.

 7. Take advantage of Illustrations and Tables.

 - The illustrations play a big part on the textbooks. Its hard to read when all you see are letters. So take advantage of Illustrations given for you.

 - Tables will give you summarized information also, and in this format it is easier for you to remember things.

 8. If there are review questions at the end of the chapter, go ahead and answer them, but again, don't torture yourself, if you know you don't really know the answer, look at the answers section immediately.

 9. And lastly, and probably the most important of all, TAKE DOWN NOTES while you are reading.

 - It is just impossible to read, understand them and remember them all the next month or even week for some. In order for you to not repeat everything, simply note down the things you've learned, in as short notes as possible, and in a way that you yourself will easily understand in the future.

 Happy Reading! :)

Just a tip on studying:

Do not read pdfs head-on and expect to learn so much from it.

 Most people have this mistake so they end up not being able to study well.

 Here is my preferred study program:

 Step 1: Do not read pdfs first, this should be the last. Take multimedia resources first.

 Step 2: Look at the dumps first, look at the answers. This is so you know what you will be studying later (and to what level are you going to need to study).

 Step 3: Install a packet-tracer or a GNS3 in your laptop/pc. Configure and practice everything you can. Remember, Hands-on skills is everything in this career!

 Step 4: When you are ready to read a PDF book, go ahead and start at the title page.

Good Luck! :) 

Types of WAN:

Branch aggregation (ipsec/sslvpn/getvpn/ravpn/dmvpn)

 Data Center Interconnect (L2VPNs: EoMPLS/VPLS/AToM)

 Internet Edge (BGP/NAT/multihoming)

 Large Branch WAN

 

 Basic WAN:

 Secure WAN (VPN/IPsec/SSL)

 Optimized WAN (WCCPv2/WAAS)

 

 Connection types:

 Leased Line:

 > E1/E3

 > E1/E3

 > dis: Costly

 > Protocols: HDLC/PPP

 > Speed: 1.544 - 45 Mbps

 

 Circuit Switching:

 > POS (Packet over SONET/SDH OC3/12/192)

 > adv: Affordable

 > dis: Less Secure

 > Protocols: HDLC/PPP

 > Speed: 155Mb to 10Gb

 
 Packet-Switching:
 
> E1/E3 pvcs
> adv: Affordable
> dis: Shared BW
> Speed: up to 45 Mb
> Protocols: FR
 
Cell-switching: 
> OC3/12/48
> adv: Private
> dis: Higher per-port cost
> Speed: up to 620 Mb
>Protocol: ATM

Metro-E:
> ethernet, GE,10GE
> adv: Affordable
> dis: Lacks inherent reliability
> Speed: up to 10 Gb
> Protocol: Ethernet/Frac-GE, Frac-10GE) 
 

Taking the Exam

 

1. Plan when to take (Schedule on a Test Center about 1 month before your exam).

2. Study Tips:

- Download the latest Dumps (P4S, Passguide, Testking, VCE files, etc)

- Do not torture yourself, read the answers the first time you study these.

- Read from books as you get curious to the answers (and the wrong answers)

- Do not force yourselves to read pdf books (Use the dumps first, then the books).

- Use multimedia resources (like cbt, knet, trainsignal, etc) 

 3. Make sure you studied well (or in real-life have memorized the dumps) :D before taking the exam.

02/05/2011 - Useful shortcuts:

#show ip int br | e una

 > this excludes the interfaces which are unassigned of an ip address.

 #show run | b router

 > begins show run in routing protocol configurations (skips interfaces and all above it)

 #show ip proto | i "

 > shows active Routing Protocols (IGP/EGP)

 #show run | s ospf

> displays router ospf section + all lines with ospf in it. 

 #show run | s router ospf

 > displays router ospf section only

 #show ip int br | i V

 > displays SVIs only (useful on switches with many ports) 

02/04/2011 - Most Common IOS show commands:

L1:

show module

show environment

show env power

show version

L2:

 show vlan brief

show int trunk

show int status

show ip int brief

show run int fa0/0

show int fa0/0 switchport

 L3:

show ip int brief

show run int fa0/0

show ip route

show ip protocols

show ip eigrp neighbors

show ip ospf neighbors

show ip eigrp int

show ip ospf int brief

BGP:

show ip bgp summary

show ip bgp

MPLS:

show mpls ldp discovery

show mpls ldp neighbor 

show ip bgp vpnv4 all summary

show ip bgp vpnv4 all

show ip route vrf <vrf-name> 

02/27/10 - Taking Advantage of the Pipe

Use the IOS pipe (very similar to Unix pipe) to your advantage.

 This can help you get more specific output.

 IOS pipe:

 include (i) - display lines only with this string.

 exclude (e) - display lines without this string.

 begin (b) - display starting first line appearance of this string.

 section (s) - display section containing this string. (section = section + include)

 redirect  - redirect output to a file

 tee -  redirect to a file and display.

 Other IOS Variants

 

 Cisco IOS XR - for GSRs (12000) and CRS (Core P-Routers), ASR 9k

 Cisco IOS XE - for  ASR 1000

Cisco NX-OS - for Nexus 5000, 7000 (higher than 6500 Catalyst) 

 

What's the difference with regular IOS?

 > OS that takes advantage of distributed architecture and high availability of these machines.

> Restartable processes.

 > Hierarchical configurations

 Note: In CRS-3/ASR9K, all LC/PLIMs have their own CPUs.

 

IOS Details

Major release: focuses on stability

 ex: 12.4 -> major release version

maintenance updates - bug fixes

 ex: 12.4(3) -> third maintenance updates

 Early Deployment (ED)

ex: 12.4(3)T -> for customers who wants new features

 General Deployment (GD)

 a status symbolizing  stability of IOS as proven by Cisco and validated by customer experiences.

Mounting

Needs the ff. tools:

 > Scissors, Inventory List, Phillip and Screw driver (+/-)

 > Jacket, food, water

 Procedure:

> Check the inventory with the serial nos of every part. 

 > Install Bracket (Make sure it is stable and tough enough) - this will be the foundation support of the equipment. The Bracket alone should be able to carry the weight of the equipment.

 > Plan where to place the Cage knots and place it.

 > Remove all modules and power supplies so the chassis will lighter upon mounting.

 > Place the equipment.

 > Screw on the sides

 > Before powering-up the equipment, make sure Circuitbreaker is on and Power-cable is plugged to the right socket.

 > Plug-in a console cable and power-on the equipment.

Site Survey:

Needs to consider the ff:

> Stability of the Floor

> Size of the equipment and the path to the Server Room.

> Equipments/tools needed during delivery (like a forklift).

 > Power requirements:

 AC: How many plugs needed, how many watts/voltage/current(A)

 DC: How many (A and B) connections needed, How many volts/current(A)

 Also, measure the distance of the DCPDB to the equipment (thru the power-ladder/raised floor)

 > ODF Location:

 Where cables will be terminated. Also measure the cable lengths.

 > Grounding Location:

 Where the ground will be connected. Also measure the cable lengths.

 > Air flows:

 Side-to-side or Front-to-back (Consider space and nearby equipments)

 > Environment:

 Room temperature, Air-conditioning, and Humidity

 > Take Pictures of major areas

 > Take measurements as much as possible and record them.

 

Nexus (Data Center Switch)

What's new in Nexus:

1. VDC - Virtual Device Context - (Making Nexus a 6500 with VM-ware capability) 

2. VPC - Virtual Port Channels - (Very similar to 6500's VSS Technology (But only the MEC part, it is not functioning as a single switch)

3. OTV - Overlay Transport Virtualization - (Provides L2 adjacency over any networks)

 Nice new casing! :)

 

 NX-OS new features:

 > License is needed (there is a 120-day grace period) for extended features

 > show commands everywhere!

 > features need to be enabled first

 >  More options after pipe.

 > show run <protocol/feature> <parameter>

 > routing table looks different

 > VDC functions like a virtual switch (up to 4)

NX-OS ne

Fiber Cables

Why we use Fiber cables instead of the usual RJ-45 copper?

> Longer length (copper - limited to up to 100m, fiber can span kilometers!)

> Lesser Loss - no radiation outside, therefore lesser loss.

> No interference/noise/crosstalk - because it is light, not affected by Electromagnetic Interferences (EMI).

> Higher Bandwidth capability - Light is usually in Terahertz range or higher, this is not possible in copper cables because at higher frequencies, radiation would be so much.

SC type - Shorter, but thicker (used for wide sfp ports)

LC type - Longer, but thinner (used for small sfp ports)

 

Caring on Fiber Cables:

- cables should never be bent 90 degrees or more.

- cable end (connectors) should be handled with care.

- Ports without X2/Xenpak modules should be sealed by its original cover/or a tape so dust wont come in.

- do not stare into the fiber end/fiber port (class 1 laser)

- If port is not coming up due to Tx/Rx issue, just try interchanging the Tx/Rx ports.

(You can also try setting duplex/speed/negotiation to auto on both ends. 

02/27/11 - More Nexus Stuff...

Common commands used in Nexus:

Switching between VDCs:

switchto vdc vdc2

exit/switchback

Saving all VDC configs:

copy run start vdc-all

Useful show commands L1/L2:

show int br

show int status

show int trunk

show spanning

show ip int br vrf VRF_NAME

show run int

show vpc

 

Copying Files To/From a USB flash drive:

First is to connect first your USB to any usb port of Nexus Sup.

dir usb1:

copy usb1://FILENAME bootflash:

copy bootflash://IOS_FILENAME usb1:

To remove usb safely:

unmount usb1

 

Creating Checkpoints:

- Checkpoints are saved configs that you may want to use for future configs.

checkpoint FILENAME

VLANs:

- Note, in Nexus, VLANs are NOT automatically created,unlike in normal IOS.

Shutdown default state:

- if interface is in shutdown state, it will not appear, while if it is up, the "no shutdown" command appears in show run output (this is reverse of normal IOS).

VPC Peer-switch:

- Makes both your Nexus Dual-Root Bridges for you Spanning-tree topology.

VPC Peer-gateway:

- Similar to what GLBP does, this feature makes the mac-address of both gateways on each Nexus appear as one on the hosts/servers connected to the L2 domain.

Viewing Recent Syslog:

show log | last 50

Creating Port-channels:

conf t

int e1/1-2

  switchport

  switchport mode trunk 

  switchport trunk allowed vlan 100,200

  no shut

  chanel-group 10 mode on

(Port-channel 10 will inherit int e1/1-2 configs)

(Any further changes should be applied to Po10 and it will be automatically copied to e1/1-e)

 

int Po10

  switchport trunk allowed vlan add 300

  spanning port type normal

Verification:
  show port-channel summay

  show run int Po10

 

Creating Port-channels that will use vPC feature:

Similar to above, just add this on both port-channel members:

 int Po10

  vpc 10

(where 10 is VPC number, good practice to use similar number to port-channel,but not required to be the same).

Verification:

show port-channel summary

show vpc

 

DC Cabling

> Negative is BLUE, Positive is BLACK

> Each power shelf consist of Multiple DC Power-modules.

> Each power shelf is powered by Primary (A) and Secondary (B) supplies.

> Each Power module therefore is powered by an A and a B (2 Breaker units)

 

Upgrading CRS-3/ASR9K (IOS-XR)

The feature upgrades are on the PIEs

The bug fixes are on the SMUs.

 To upgrade an IOS-XR software, you have to copy first the upgrade package:

admin

install add tftp://1.1.1.1/FILE.tar

you will then be extracting these on your disk/harddisk.

install activate disk0:PIE/SMU-FILES_separated by space sync

(will automatically reload)

 install commit

Upgrade the other stuff such as rommon:

upgrade fpd...

(system will reload) 

05/08/2011  MPLS Core Verification in IOS-XR

show ip int brief | e una

show int description | e admin-down

show route

ping <ip>

ping <ip> vrf

show vrf all 

show vrf interface

show  bundle

show bundle brief

show bundle bundle-e #

show ospf neighbor

show ospf int brief

show route ospf

show bgp vpnv4 all summary

show bgp vpnv6 unicast all summary

show bgp ipv4 mdt all summary 

show bgp l2vpn vpls all summary

show bgp l2vpn vpws all summary

show bgp all all summary

show mpls ldp interface

show mpls ldp discovery

show mpls ldp neighbor

show mpls forwarding

show bfd session

show ipv4 access #

show rpl

 

CCNA Exam:

Two options:

 1. CCNA 640-802 (single, original exam)

> 90 min + 30 (for non-english native language countries) = 2 hours

 > Passing score:853???

 > Validity: 3 years

 > More preferred by many

 2. ICND1 + ICND2

> Double the price, double the hassle.

> Lesser Topics on each exam. 

01/05/2011

Case 1: BGP peering problem

- BGP is having problem peering based on captured logs (intermittent)

- show ip route of the peering ip shows changing next-hop.

- Solution is to change distribute-list acl which denies but does not have permit any at the end.

 Case 2: MPLS is propagating routes across site CEs, but label in incomplete at P-router:

- Solution: Loopback0 which is used in LDP must really be a /32, otherwise it wouldn't send labels to its LDP neighbors.

 Case 3: Redundant ISP link which uses IP SLA + EOT doesn't work on failover

- NAT for the other ISP was not configured

- Short timeout for nat will affect applications, therefore, EEM was used to track the state change of track used by IP SLA.

Dual Stub Routers works in OSPF 01/15/2011

Using stub areas (totally stub) in distribution routers helps decrease the routes received by distribution switches to just default routes instead of the full OSPF routes. Redundancy is still achieved and this will work as long as there will be no other L3 links to the distribution aside from the Core links and the Access links (non-router access, servers).

Load-Balancng

CEF's default load-balancing algorithm: per-destination ip address

If there is a layer of Firewalls on your network, then you should stop load-balancing beneath those firewalls. This will be done by increasing the ospf's cost on the interfaces of firewall's redundant connection to the lower-layer (aggregation probably). This should be applied on both interfaces of the links.

Use this command to view Load-balancing behavior of CEF:

#show ip cef 10.1.1.1 internal

My References

I have tons of books, audio, video and presentation references when it comes to cisco technical stuffs. This is where the "depth of references" come into play. The deeper your library is, the better you are in your technical work because you will realize later that you will not be able to know everything, all you have to do is to have a minor grasp on everything else, and look at the books, or in the internet as your reference. We're not in school anyway, we are allowed to open notes and books, or even the internet.

 

MAIN:

Audio - INE CCIE R&S version 4 - by Scott Morris and Anthony Sequierra

          - IPEXPERT audio version 3 and version 2 by Scott Morris

          - INE IP Routing by Brian Dennis

Video - IPEXPERT video on demand by Scott Morris

         - INE version 4 by Brian Dennis and Bryan McGahan

         - IPv6 by Anthony Sequierra 

         - CBT nuggets: CCIE, CCNP, CCNA by  Jeremy Chiora

Knet - BGP, MPLS, QoS

Workbooks - Narbik Kocharians Vol. 1 and Vol. 2

                 - INE workbooks version 4 and version 5 (vol 1 and 2)

Textbooks -  MPLS Configuration on Cisco IOS

                - Troubleshooting IP Routing Protocols

                - Cisco IOS Cookbook 2nd ed.  (O'Reilly) 

 

DMVPN 01/26/2012

DMVPN (Dynamic Multipoint VPN) is a combination of technologies that creates a hub and spoke tunneled network.

It uses all these 5 protocols

1. NHRP - Next-hop Resolution Protocol

2. IPSEC - Dynamic IPSEC VPN

3. mGRE - multipoint GRE Tunnels

4. Routing Protocols (Static, EIGRP, RIP, OSPF, BGP)

5. CEF - Cisco Express Forwarding

 

The use of DMVPN is for Scalable Hub and Spoke networks that needs Spoke to spoke tunneling and IPSEC Encryption.

 NHRP is used so that next-hops of non-directly-connected routes can be resolved dynamically.

IPSEC is for data encryption

mGRE is for Tunneling over the Public/Private network over which the DMVPN is running.

Routing Protocols is how Networks on each Spoke see each other via the Tunnels.

CEF is the forwarding used in DMVPN.

 

 

Configuration:

 

Hub:

conf t

hostname HQ_Router

crypto isakmp  policy 1

  authentication pre-share

  encryption 3des

  hash sha

  group 2

  lifetime 86400

crypto isakmp key CISCO address 0.0.0.0 0.0.0.0

crypto ipsec transform-set ESP-3DES-SHA esp-sha-hmac esp-3des

  mode transport

crypto ipsec profile DMVPN_PROFILE

  set transform-set ESP-3DES-SHA

interface fa0/0

  ip address 172.16.1.1 255.255.255.0

interface Tunnel0

  bandwidth 128

  delay 100

  ip nhrp holdtime 360

  ip mtu 1400 

  ip tcp adjust-mss 1360 

  ip nhrp network-id 1

  ip nhrp authentication CISCO

  ip nhrp map multicast dynamic

  ip address 10.0.0.1 255.255.255.0

  no ip split-horizon eigrp 1

  no ip next-hop-self eigrp 1

  tunnel source fa0/0

  tunnel mode gre multipoint

  tunnel key 100

  tunnel protection ipsec profile DMVPN_PROFILE 

 router eigrp 1

  no auto

  network 10.0.0.0 0.255.255.255 (Tunnel network)

  network x.x.x.x y.y.y.y (LAN network)

ip route 0.0.0.0 0.0.0.0 Tunnel0 

 

Note: in the spoke, the only difference is the nhrp configuration in the tunnel:

 

Spoke:

interfaec Tunnel0 

  ip nhrp nhs 10.0.0.1

  ip nhrp map multicast <fa0/0 of Hub>

  ip nhrp map 10.0.0.1 <fa0/0 of Hub> 

 

 Some Explanations:

- network-id must be the same on Hub and all spokes

- IPSEC configuration must be consistent (same) on Hub and all spokes.

- Authenticaiton, if configured, must be the same 

- Configs such as holdtime, mtu, tcp adjustt-mss, delay authentication are all optional

- eigrp split-horizon should be disabled, otherwise LAN networks will not be propagated on a NBMA network.

- eigrp no ip next-hop-self is so that Hub will not be seen as next-hop by the spokes 

- The default route to tunnel0 says default route will be sent to the tunnel. 

Navigating the new Cisco website 01/30/2012

This one is very useful for newbies. Because from here is a lot of useful information and a lot of tools you can use for troubleshooting, installation, design, mounting, specs-looking, compatibility, bug-scrubbing, etc.

 

Main Menu:

Products and Services - More of Customers/Sales/Presales use. This is where the list of products and services from cisco is listed.

Support - The most useful for us. This is where Detailed Technical informations are located. 

How to buy - not useful for us.

Training and Events - Useful for you if you are taking Certifications. Complete list of Certifications, Descriptions, prerequisites, etc.

Partners - not useful for us.

 

Support Tab:

On this tab are a list of Cisco Products (Hardware/Software)

 

Routers

Switches

Wireless

Security

Networking Software (IOS and NX-OS)

 

Below are the very useful tools for us:

1. Bug Toolkit

2. Output Interpreter

3. Error Message Decoder

4. Software Advisor 

5. Command Lookup Tool

 

 

Release and General Information

Reference Guides

Design

Install and Upgrade

Configure

Maintain and Operate

Troubleshoot and Alerts 

 

 

Inter-AS Option B (ASBR approach next-hop-self method) 2/6/2012

Click to add text, images, and other content

R1: (CE-1)

conf t

hostname R1-CE1

interface fa0/0

ip address 10.1.12.1 255.255.255.0

no shut

int loopback0

ip address 11.11.11.11 255.255.255.0

router ospf 10

router-id 1.1.1.1

network 11.11.11.11 0.0.0.0 area 0

network 10.1.12.1 0.0.0.0 area 0

end

R2: (PE1)

conf t

hostname R2-PE1

mpls ldp router-id lo0 force

mpls label protocol ldp

ip vrf TEST

rd 10:10

route-target both 10:10

interface fa0/0

ip vrf forwarding TEST

ip address 10.1.12.2 255.255.255.0

no shut

interface lo0

ip address 2.2.2.2 255.255.255.255

interface fa0/1

ip address 10.1.23.2 255.255.255.0

mpls ip

no shut

router ospf 10 vrf TEST

router-id 2.2.2.22

network 10.1.12.2 0.0.0.0 area 0

redistribute bgp 65001 subnets

router ospf 1

router-id 2.2.2.2

network 10.1.23.2 0.0.0.0 area 0

network 2.2.2.2 0.0.0.0 area 0

router bgp 65001

bgp router-id 2.2.2.2

no bgp default ipv4-unicast

neighbor 4.4.4.4 remote-as 65001

neighbor 4.4.4.4 update-source lo0

address-family vpnv4

neigh 4.4.4.4 activate

neigh 4.4.4.4 send-community extended

neigh 4.4.4.4 next-hop-self

address-family ipv4 vrf TEST

redistribute ospf 10 vrf TEST match internal external 2

end

R3: (P-router)

conf t

hostname R3-P1

mpls ldp router-id lo0 force

mpls label protocol ldp

int fa0/1

ip address 10.1.23.3 255.255.255.0

mpls ip

no shut

int fa0/0

ip address 10.1.34.3 255.255.255.0

mpls ip

no shut

router ospf 1

router-id 3.3.3.3

network 10.1.23.3 0.0.0.0 area 0

network 10.1.34.3 0.0.0.0 area 0

network 3.3.3.3 0.0.0.0 area 0

end

R4: (PE2-ASBR1)

conf t

hostname R4-PE2-ASBR1

mpls ldp router-id lo0 force

mpls label protocol ldp

interface fa0/1

ip address 10.1.45.4 255.255.255.0

mpls bgp forwarding

no shut

interface lo0

ip address 4.4.4.4 255.255.255.255

interface fa0/0

ip address 10.1.34.4 255.255.255.0

mpls ip

no shut

router ospf 1

router-id 4.4.4.4

network 10.1.34.4 0.0.0.0 area 0

network 4.4.4.4 0.0.0.0 area 0

router bgp 65001

bgp router-id 4.4.4.4

no bgp default ipv4-unicast

no bgp default route-target filter

neighbor 2.2.2.2 remote-as 65001

neighbor 2.2.2.2 update-source lo0

neighbor 10.1.45.5 remote-as 65002

address-family vpnv4

neighbor 2.2.2.2 activate

neighbor 2.2.2.2 send-community extended

neighbor 10.1.45.5 activate

neighbor 10.1.45.5 send-community extended

end

R5: (PE3-ASBR2)

conf t

hostname R5-PE3-ASBR2

mpls ldp router-id lo0 force

mpls label protocol ldp

interface fa0/1

ip address 10.1.45.5 255.255.255.0

mpls bgp forwarding

no shut

interface lo0

ip address 5.5.5.5 255.255.255.255

interface fa0/0

ip address 10.1.56.5 255.255.255.0

mpls ip

no shut

router ospf 1

router-id 5.5.5.5

network 10.1.56.5 0.0.0.0 area 0

network 5.5.5.5 0.0.0.0 area 0

router bgp 65002

bgp router-id 5.5.5.5

no bgp default ipv4-unicast

neighbor 7.7.7.7 remote-as 65001

neighbor 7.7.7.7 update-source lo0

neighbor 10.1.45.4 remote-as 65001

address-family vpnv4

neighbor 7.7.7.7 activate

neighbor 7.7.7.7 send-community extended

neighbor 7.7.7.7 next-hop-self

neighbor 10.1.45.4 activate

neighbor 10.1.45.4 send-community extended

end

R6: (P-router)

conf t

hostname R6-P2

mpls ldp router-id lo0 force

mpls label protocol ldp

int fa0/0

ip address 10.1.56.6 255.255.255.0

mpls ip

no shut

int fa0/1

ip address 10.1.67.6 255.255.255.0

mpls ip

no shut

router ospf 1

router-id 6.6.6.6

network 10.1.56.6 0.0.0.0 area 0

network 10.1.67.6 0.0.0.0 area 0

network 3.3.3.3 0.0.0.0 area 0

end

R7: (PE4)

conf t

hostname R7-PE4

mpls ldp router-id lo0 force

mpls label protocol ldp

ip vrf TEST

rd 10:10

route-target both 10:10

interface fa0/0

ip vrf forwarding TEST

ip address 10.1.78.7 255.255.255.0

no shut

interface lo0

ip address 7.7.7.7 255.255.255.255

interface fa0/1

ip address 10.1.67.7 255.255.255.0

mpls ip

no shut

redistribute bgp 65002 subnets

router ospf 1

router-id 7.7.7.7

network 10.1.67.7 0.0.0.0 area 0

network 7.7.7.7 0.0.0.0 area 0

router bgp 65002

bgp router-id 7.7.7.7

no bgp default ipv4-unicast

no bgp default route-target filter

neighbor 5.5.5.5 remote-as 65002

neighbor 5.5.5.5 update-source lo0

address-family vpnv4

neigh 5.5.5.5 activate

neigh 5.5.5.5 send-community extended

address-family ipv4 vrf TEST

redistribute ospf 10 vrf TEST match internal external 2

end

R8: (CE2)

conf t

hostname R8-CE2

interface fa0/0

ip address 10.1.78.8 255.255.255.0

no shut

int loopback0

ip address 88.88.88.88 255.255.255.0

router ospf 10

router-id 8.8.8.8

network 88.88.88.88 0.0.0.0 area 0

network 10.1.78.8 0.0.0.0 area 0

end

 

Inter-AS Option A

- Back to back VRF

- Simple, just treat the Inter-as Link as normal PE-CE interfaces (The PE to the other AS is your CE and vice-versa).

- Use subinterfaces to be able to handle multiple VRFs in a single physical interface.

- Problem is scalability - more vrf, more subinterfaces configured.
- Advantage is simplicity and ease of configuration.

 

Inter-AS Option B

- eBGP between ASBRs.

- use eBGP label exchange to assign labels to packets traversing the Inter-AS link.

 

CSC:

----(vrf)--PE1---LDP(mpls)---P1---(ipv4 ebgp send-label)--(vrf)--PE3-P-PE4--

(vrf)--(ipv4 ebgp send-label)--P2---LDP(mpls)---PE2--(vrf)---- 

 
Carier (higher Tier):

- Normal MPLS with ebgp and send-label at PE-CE

Customer Carier (lower Tier):

- Normal MPLS with ebgp and send-label at P-router edge 

Installation (Mounting and Cabling)

1. Site Survey - Rack location, Cabling path, Circuit Breaker availability, Fiber cable paths.

2. Power Cabling - Activities include Latag, power-tapping, checking the type of plug (male/female/twistlock/ordinary), length of power cables

3. Fiber Cables - Length of cables issues (SR vs LR, MMF vs SMF), SFPs used (X2, Xenpak, XFP, SFP), availability of slot in Router/Switch, module to be used, insertion of SFPs/modules.

4. Check the cage knots if available and if sufficient, and if bolts and knots will fit both the Equipment and Rack, and if measurement is exact with rack and equipment. 

IOS-XR Basics 03/24/2012

commit

rollback

show config - displays configs that weren't yet commited

show config merge - displays show run after you commit the commands

show version

show version brief

PIE - feature patches

SMU - bug fixes 

PLIMs - Physical Layer Interface Module

MSC - Modular Service Card 

SIP - 

SPA -  

 

 

 

Route-reflectors

Originator-ID - used to prevent loops by dropping the update when it came back to the route originator.

Cluster-ID - by default is the bgp router-id. Used for loop prevention by using the cluster-list.

Cluster-List - List of all the Route-reflector cluster-ids that was traversed by the route.

Best Practice:

Peer between Route-reflectors, then Configure the same Cluster-id on both RRs. 

except, when redundant link to RRs broke, this will prevent routes from propagating between the 2 RRs. In this case, just remove the Cluster config making them separate clusters again.

Advantage of being in a single Cluster (2 RRs) - save memory resources on large route updates, if left to separate clusters, will eat up more memory but will leave no problem. 

 

Members Area

Arcade

Testimonials

Recent Blog Entries

Recent Forum Posts

Newest Members